Power loss on 4 Litre R

Talk about your cars

Power loss on 4 Litre R

Postby Stephen Mooney » Sun Jul 08, 2007 2:56 pm

I thought some of you may be interested to know what was causing the power loss with my 4 Litre R. There was an in line fuel filter in the boot, between the tank and the pump, which was completely clogged with dirt. It was well hidden and I didn't know it was there. Anyway, I fitted a new filter and it's been fine. I don't think they were fitted as part of the original spec.

Thanks to those who offerred help.

:)
Stephen Mooney
 
Posts: 28
Joined: Sat Jan 06, 2007 11:17 am
Location: Manchester

Return to Owners cars

Who is online

Users browsing this forum: No registered users and 2 guests

cron

AIMS OF THE CLUB

 

a) Generally to help and encourage members to maintain these fine cars in good running order and appearance.


b) To organise rallies and meetings nationwide, and to field an annual Show Day. Members can compete at these events for trophies, these being awarded for the best cars in restoration, and most used classes.

c) To offer technical advice to those people seeking help. We also help those not wishing to carry out their own repairs, as some of our members are motor engineers and specialise in the various models within the club.


d) Spares are offered for sale through the club magazine, and several of our members have stocks of spares for sale.

Forum contact: webmaster@vpoc.info | General contact: info@vpoc.info

© VPOC 2012 - Site Design by sweetjamgraphics.com